Network Interface Addendum

Anybus® X-gateway
LonWorks Interface

Rev. 1.10
# Table of Contents

## Preface
- About This Document
  - How To Use This Document: P-1
  - Important User Information: P-1
  - Related Documentation: P-1
  - Revision List: P-1
  - Conventions Used in This Document: P-2
  - Support: P-2

## Chapter 1 About the Anybus X-gateway LonWorks Interface
- External View: 1-1
  - LonWorks Status LED:s: 1-1
  - Connectors and Switches: 1-1
- Software Installation: 1-2
  - System Requirements: 1-2
  - Installation Procedure: 1-2

## Chapter 2 Data Exchange
- Data Exchange Basics: 2-1
- Data Sizes: 2-1
- Control & Status Words: 2-1

## Chapter 3 Anybus LWTool
- General: 3-1
- User Interface Overview: 3-2
  - Node Menu: 3-2
  - Network Variable Menu: 3-3
  - Config Properties Menu: 3-4
  - Set Memory Mapping: 3-5
- File Management: 3-5
  - Project Files (.PRJ): 3-5
  - Templates: 3-5
  - External Interface Files (.XIF): 3-5
  - Node Documentation Files (.HTML): 3-6
  - Configuration Files (.DAT): 3-6
- Quick Start: 3-7
  - Create a non-LonMark Compliant Project & Add Network Variables: 3-7
  - Open an Existing Project & Import an Object With Predefined Variables: 3-8
  - Create a LonMark Compliant Project & Add an Empty Object: 3-9

## Chapter 4 The Firmware Download Utility
- General: 4-1
- Configuration: 4-1
Appendix A Technical Specification

- Bus Interface Details: A-1
- Bus Connector: A-1
About This Document

How To Use This Document

This document describes the various features of the Anybus X-gateway LonWorks interface, network specific installation procedures and various network specific details. General information and operating instructions for the Anybus X-gateway is available in the Anybus X-gateway User Manual.

The reader of this document is expected to have basic knowledge in the LonWorks networking system, and communication systems in general.

For further information, documentation etc., please visit the HMS website, ‘www.anybus.com’.

Important User Information

The data and illustrations found in this document are not binding. We, HMS Industrial Networks AB, reserve the right to modify our products in line with our policy of continuous product development. The information in this document is subject to change without notice and should not be considered as a commitment by HMS Industrial Networks AB. HMS Industrial Networks AB assumes no responsibility for any errors that may appear in this document.

There are many applications of this product. Those responsible for the use of this device must ensure that all the necessary steps have been taken to verify that the application meets all performance and safety requirements including any applicable laws, regulations, codes, and standards.

Anybus® is a registered trademark of HMS Industrial Networks AB. All other trademarks are the property of their respective holders.

Related Documentation

<table>
<thead>
<tr>
<th>Document</th>
<th>Author</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anybus X-gateway User Manual</td>
<td>HMS</td>
</tr>
<tr>
<td>Anybus-S LonWorks Fieldbus Appendix</td>
<td></td>
</tr>
<tr>
<td>LonMark Application-Layer Interoperability Guidelines ver 3.3</td>
<td>LonMark</td>
</tr>
<tr>
<td>Variable Speed Motor Drive Profile ver 1.1</td>
<td></td>
</tr>
</tbody>
</table>

Revision List

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Author</th>
<th>Chapter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>2004-03-10</td>
<td>PeP</td>
<td>All</td>
<td>First version</td>
</tr>
<tr>
<td>1.01</td>
<td>2004-04-05</td>
<td>PeP</td>
<td>2, 3 &amp; A</td>
<td>Minor corrections &amp; updates</td>
</tr>
<tr>
<td>1.10</td>
<td>2009-06-10</td>
<td>KeL</td>
<td>All</td>
<td>Minor updates throughout the whole document</td>
</tr>
</tbody>
</table>
Conventions Used in This Document

The following conventions are used throughout this document:

- Numbered lists provide sequential steps
- Bulleted lists provide information, not procedural steps
- The term ‘X-gateway’ is used when referring to the Anybus X-gateway
- The term ‘Lonworks interface’ is used when referring to the Anybus X-gateway LonWorks interface.
- The term ‘user manual’ is used when referring to the Anybus X-gateway User Manual.
- Hexadecimal values are written in the format NNNNh, where NNNN is the hexadecimal value.
- 16/32 bit values are generally stored in Motorola (big endian) format unless otherwise stated.
- The term ‘byte’ always refers to a string of 8 bits.

Support

**HMS Sweden (Head Office)**

E-mail: support@hms-networks.com  
Phone: +46 (0) 35 - 17 29 20  
Fax: +46 (0) 35 - 17 29 09  
Online: www.anybus.com

**HMS North America**

E-mail: us-support@hms-networks.com  
Phone: +1-312-829-0605  
Toll Free: 888-8-Anybus  
Fax: +1-312-738-5873  
Online: www.anybus.com

**HMS Germany**

E-mail: ge-support@hms-networks.com  
Phone: +49-721-96472-0  
Fax: +49-721-964-7210  
Online: www.anybus.com

**HMS Japan**

E-mail: jp-support@hms-networks.com  
Phone: +81-45-478-5340  
Fax: +81-45-476-0315  
Online: www.anybus.com

**HMS China**

E-mail: cn-support@hms-networks.com  
Phone: +86 10 8532 3023  
Online: www.anybus.com
HMS Italy
E-mail: it-support@hms-networks.com
Phone: +39 039 59662 27
Fax: +39 039 59662 31
Online: www.anybus.com

HMS France
E-mail: mta@hms-networks.com
Phone: +33 (0) 3 89 32 76 41
Fax: +33 (0) 3 89 32 76 31
Online: www.anybus.com
Chapter 1

About the Anybus X-gateway LonWorks Interface

The Anybus X-gateway LonWorks interface provides a high performance connection to LonWorks networks. The LonWorks network variable implementation can be fully customized and stored in FLASH memory. To simplify this process, a PC-based utility called Anybus LWTool is used to specify the desired set of network variables and map them towards the Input- and Output buffers. The finished configuration can then be downloaded into the LonWorks interface either via RS-232 or Ethernet.

External View

LonWorks Status LED:s

<table>
<thead>
<tr>
<th>LED</th>
<th>Colour</th>
<th>Indication</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service</td>
<td>Green</td>
<td>Node is unconfigured and applicationless; errors detected during Neuron self test.</td>
</tr>
<tr>
<td></td>
<td>Green, flashing</td>
<td>Node has an application but is not yet installed in a network (unconfigured)</td>
</tr>
<tr>
<td></td>
<td>Off</td>
<td>Node is configured and installed in a network</td>
</tr>
<tr>
<td>Wink</td>
<td>Red, flashing</td>
<td>A wink command is received on the LonWorks network</td>
</tr>
<tr>
<td></td>
<td>Off</td>
<td>Normal operation</td>
</tr>
<tr>
<td>MS</td>
<td>Green</td>
<td>Interface has been initialized correctly and is working ok</td>
</tr>
<tr>
<td></td>
<td>Red</td>
<td>Major error</td>
</tr>
<tr>
<td></td>
<td>Red, flashing</td>
<td>Minor error</td>
</tr>
</tbody>
</table>

Gateway Status (Consult the user manual for further details)

Connectors and Switches

<table>
<thead>
<tr>
<th>#</th>
<th>Description</th>
</tr>
</thead>
</table>
| 1 | Lonworks connector  
See A-1 “Bus Connector” |
| 2 | Service Pin button  
See A-1 “Bus Connector” |
| 3 | Gateway power connector  
(Consult the user manual for further details) |
| 4 | Gateway config connector  
(Consult the user manual for further details) |

1. Ethernet gateway configurations only.
Software Installation

System Requirements

Minimum:
- Windows 2000/XP/Vista
- Pentium class CPU running at 133 MHz
- 32 Mb RAM
- 800x600 resolution color display

Recommended:
- Windows 2000/XP
- Pentium class CPU running at 200 MHz or higher
- 64 Mb RAM
- 1024x768 resolution display
- 16 bit color

Installation Procedure

The installation screen should appear automatically upon inserting the supplied software CD. If not, open the CD device and double click on ‘index.html’.
- Install Anybus LWTool by clicking ‘LWTool’ and follow the on screen instructions.
- Install the Anybus-X serial hardware driver by clicking ‘Hardware driver’ and follow the on screen instructions.
- Click ‘Readme.txt’ to read supplementary information such as release notes etc.
Data Exchange

Data Exchange Basics

The LonWorks interface exchanges data with other nodes on the LonWorks network based on the network variable configuration created using Anybus LWTool. The network variable data (from now on referred to as LonWorks network I/O) is forwarded to the “other network interface” side of the gateway and vice versa according to the figure below.

The actual structure of the exchanged LonWorks network I/O is determined by the configuration created in the LWTool utility. For more information, see 3-1 “Anybus LWTool”.

Data Sizes

The input/output data sizes of the LonWorks interface is determined by the size of the actual configuration created using the LWTool utility and cannot be set via the Gateway Config interface.

For more information, see 3-1 “Anybus LWTool”.

Control & Status Words

In the figure above, the Control & Status words are not enabled for the other network. Enabling these words will affect the LonWorks network I/O associated with the same data region; this must be taken into consideration when configuring the LonWorks network.

For more information regarding the Control & Status words, consult the main user manual.
Anybus LWTool

General

Anybus LWTool is an easy to use configuration tool suitable for the Anybus X-gateway LonWorks interface. It provides a user-friendly way of specifying a desired set of network variables and map them to the Input- and Output data areas. The finished configuration can then be downloaded via the HMS Firmware Download utility, see 4-1 “The Firmware Download Utility”.

A fast learning curve and visual user interface allows complete network configurations to be built without spending precious time learning a new program.

(For installation instructions, see 1-2 “Software Installation”).

Nodes can be made to be either LonMark compliant, or customized to fit a specific application. Customized configurations is be made up of User defined Variables only, while LonMark compliant nodes require predefined Standard Network Variables.

Anybus LWTool provides a template which can be used when creating a LonMark compliant project based on the 6010 Variable Speed Motor Drive profile. It is also possible to create custom implementations “from scratch” using an empty template.

Furthermore, projects and objects can be stored to build a custom library, resulting in a more efficient way to do the next project in the same area of application; just open a suitable project and make the necessary adjustments and/or add a suitable object.
User Interface Overview

Node Menu

The following window appears when starting the Anybus LWTool utility:

1. Additional info
   This information will be presented in the Self Documentation string, seen by the network management tool. Choose a suitable name for the node.

2. Program ID
   This configuration entry determines if the configuration should comply with a LonMark approved Functional Profile or not.
   - **LonMark compliant**
     When choosing LonMark, the boxes need to be filled in. This can be generated with the Program ID calculator. Consult the LONMARK® Application Layer Interoperability Guidelines for more information.
   - **ASCII**
     This field is used when no LonMark profiles are used, and contains an 8 character description of the node/product in ASCII format.

3. Network variable alias table
   Network variable aliases are required on a node when a single network variable output on the node must be connected to two or more network variable inputs on another node.

4. Standard transceiver type
   The LonWorks interface currently only support the FT-X1 Transceiver type.
Network Variable Menu

When adding a Network Variable, the following window appears:

1. **Name**
   The network variable name should begin with ‘nvi’ or ‘nvo’ depending on if it is an input or an output variable, e.g. ‘nviChillerEnable’ and ‘nvoOnOff’

2. **SNVT Type**
   This field is used to specify the SNVT type, or select a User defined variable (UNVT).

3. **SNVT Type Size**
   When using the UNVT type, the Variable type size must be set.

4. **Selfdoc**
   This string is generated automatically. To better understand the meaning of the string, consult the LONMARK® Application Layer Interoperability Guidelines.

5. **Member Nr**
   This is the variable index in the object. Consult the specific LonMark Profile object in the LONMARK® Application Layer Interoperability Guidelines for more information. In the 8040 object, index of nviChillerEnable is 1, index of nvoActiveSetpt is 4 and so on.

6. **Add info**
   Information entered here will be added after the semicolon in the self documentation string. The information could be for example 'ChillerEnable' for ‘nviChillerEnable’.

7. **Directions**
   This field specifies the direction of the variable; a green icon indicates an input variable, a red icon indicates an output variable.

8. **Class**
   This information is specified for each variable in the Object of a Profile

9. **Default Service Type**
   Set by default as ‘Acknowledged’. Consult the LONMARK® Application Layer Interoperability Guidelines for further information.

10. **Service type may be modified**
    Set if the network management tool should be able to change service type (recommended in most cases)

11. **Use polling**
    This functionality is for input variables (nvi’s) only. If this option is enabled, the LMS will send a network variable poll message to the connected output variable (‘nvo’) to synchronize the variable during start-up.
Config Properties Menu

When adding a Variable in the Configuration Properties, the following window will appear:

1. **Name**
   The name should begin with ‘nci’, e.g. ‘nciLocation’

2. **Selfdoc**
   For non LonMark compliant nodes it is possible to add additional information (see previous page). For LonMark compliant nodes, consult the LONMARK® Application Layer Interoperability Guidelines for more information about the self documentation string.

3. **SCPT Type**
   This field specifies the SCPT variable type for the nci-name. If a user defined variable is used (UCPT), Index and Scope has to be entered. (see below)

4. **Index**
   When using UCPT variables, this field should contain the index number. (Consult the LONMARK® Application Layer Interoperability Guidelines for specific information.)

5. **Scope**
   This field is only used when using UCPT variables, consult the LONMARK® Application Layer Interoperability Guidelines for specific information.

6. **SNVT Type**
   When using UCPT variables, this field should contain a suitable SNVT variable.

7. **Class**
   Consult the LONMARK® Application Layer Interoperability Guidelines for more information.

8. **Default Service Type**
   Set by default as ‘Acknowledged’; consult the LONMARK® Application Layer Interoperability Guidelines for further information.

9. **Set initial value**: This field is used to set the initial value in hexadecimal “raw-data” form, i.e. if the range of the variable is \(-163.840\%\) to \(163.830\%\) (0.005%), this means that each step is 0.005%. If you want to set 100% as default, it would be \(100/0.005\) which is \(20000 = 4E,20\) in HEX

10. **Only changeable when offline**: When this option is enabled, it is only possible to make changes to the variable when the node is off line.

11. **Service type may be modified**: This option should be set if the network management tool should be able to change the service type (recommended in most cases)

12. **Config applies to…**: This entry defines the scope of the configuration property. Configuration properties that belong to an object shall be declared as a part of the object and not declared as a part of the node. Similarly, a configuration property associated with a specific network variable(s) shall be declared as belonging to the network variable(s) and not the object or the node. Consult the LONMARK® Application Layer Interoperability Guidelines for more information.
Set Memory Mapping

The memory map determines the structure of the LonWorks network data images, i.e. it specifies the location of the network variables in the Incoming- and Outgoing Data buffers (consult the user manual for further information).

To edit the memory map, select the ‘Set Memory Mapping’ entry in the ‘Tools’ menu.

The ‘Mem Start’ column holds the offset locations for the network variables in the Input- and Output Data areas.

There are two ways of doing the mapping:

- **Automatically (1)**
  
  By clicking this button, Anybus LWTool will automatically create a memory map for you. This map can then be altered manually, see below.

- **Manually (1 & 2)**
  
  The physical location of each Network Variable can be adjusted manually by entering the offset location in the ‘Mem.start’ field (2) and clicking the ‘Set value’ button (3) (The ‘Memory End’ value will be adjusted accordingly by the program).

File Management

Project Files (.PRJ)

The configuration can be saved for later use using the menu entries ‘Save’ and ‘Save As...’ in the ‘File’ menu. To retrieve the saved project at a later stage, use the ‘Open’ entry.

Please note that project files cannot be downloaded directly into the LonWorks interface. To do this, the project must be exported as a Configuration File (.DAT), see 3-6 “Configuration Files (.DAT)”.

Templates

Projects can be saved as templates to be used as a basis for new implementations. To create a new template, save the project in the ‘\templates\’ sub folder in the Anybus LWTool program folder.

To use a template, select the ‘New’ entry in the ‘File’ menu. Select the desired template in the dialog box that follows and click ‘OK’.

External Interface Files (.XIF)

This file is used by the Network Management tool when installing the LonWorks interface. To export a .XIF file, select the ‘XIF File’ entry in the ‘Export’ menu.

It is also possible to import .XIF files from existing products with similar functionality to use as a basis for new implementations. To import an existing .XIF file, simply select the ‘XIF File’ entry in the ‘Import’ menu.
Node Documentation Files (.HTML)

A node documentation file contains information about the configuration in standard .HTML format.

To export a node documentation file, select the ‘Node Documentation (HTML)’ entry in the ‘Export’ menu.

**Note:** It is not possible to import Node Documentation files. Be sure to save the project using the ‘Save’ / ‘Save as’ entries in the ‘File’ menu.

Configuration Files (.DAT)

The finished configuration can be exported as a .DAT file to be downloaded into the LonWorks interface using the Firmware Download utility (see A-1 “HMS Firmware Download Utility”).

**Note:** It is not possible to import .DAT files into the Anybus LWTool utility. Be sure to save the project using the ‘Save’ / ‘Save as’ functions in the ‘File’ menu.
Quick Start

Create a non-LonMark Compliant Project & Add Network Variables

After starting Anybus LWTool, select the ‘New’ entry in the ‘File’ menu, and choose ‘Empty Object’. This gives the node a Virtual Object where network variables and Configuration Properties can be added by right clicking on ‘Network Variables’ / ‘Configuration Properties’, and choosing ‘Add Network variable’ / ‘Add Config Property’

1. Select ‘Node’ and enter a name for the node under ‘Additional info’ in ‘Node Options’
2. Select ‘ASCII’ and write max. 8 character name for ‘Program ID’
3. Enter no. of entries in the ‘Network Variable alias table’
4. Add network variables by right clicking on ‘Network Variables’ and select ‘Add network variable’
5. Change the name of the variable to either to ‘nvi’ or ‘nvo’.
6. Change SNVT type to UNVT (User defined).
7. The ‘Member number’ will increase automatically, but can be altered manually if necessary.
8. Enter the name in ‘Add. info’.
9. Enter the length of the UNVT variable
10. Select the direction of the variable (‘In’ or ‘Out’)
11. Select the ‘Manufacturer’ entry under ‘Class’
12. Select the desired ‘Default Service Type’
13. If no special customer demands are required, enable ‘Service type may be modified’
14. ‘Use polling’ - this functionality is for ‘nvi’s’ only. If this option is selected, the LMS will send a network variable poll message to the connected ‘nvo’ to synchronize the variable during start-up. Repeat until all network variables are added.

15. Right click on ‘Config Properties’ and select ‘Add Config Property’

16. Enter the name of the variable using ‘nci’ in the beginning of the variable under ‘Name’

17. Enter the name without ‘nci’ under ‘Selfdoc’

18. Select SCPT type or use a UCPT if you need something not listed. Note that when using UCPT, additional information must be entered (‘Variable Index’ and ‘SNVT Type’)

19. Choose Class

20. Choose the Default Service Type

21. If necessary, set the initial value by clicking on the ‘Initial Value’ button.

22. Only changeable when offline: Make it possible to do changes to the variable only when the node is offline

23. **Service type may be modified:** Enable this option if the network management tool should be able to change service type (recommended in most cases)

24. **Scope:** This declaration defines the scope of the configuration property. Configuration properties that belong to an object shall be declared as a part of the object and not declared as a part of the node. Similarly a configuration property that is associated with a specific network variable(s) shall be declared as belonging to the network variable(s) and not the object or the node. See LONMARK® Application Layer Interoperability Guidelines for more information.

25. Save the project using the ‘Save as’ function in the ‘File’ menu

26. Export the project as XIF/Configuration File/Node Documentation file using the functions in the ‘Export’ menu.

Open an Existing Project & Import an Object With Predefined Variables

1. Start Anybus LWTool
2. Click the right mouse button on ‘Node’
3. Select ‘Import object’
4. Select ‘8040_10 Chiller Controller.lbj’
5. Click ‘Open’
Create a LonMark Compliant Project & Add an Empty Object

1. Create a new project using the ‘New’ entry in the ‘File’ menu.
2. Select ‘Empty Project’ and click ‘OK’.
3. Enter ‘Additional info’ and choose ‘LonMark’ under ‘Program ID’
4. Click on the ‘Program ID calculator’ and select manufacturer, device class, usage and other settings. The Program ID will then be calculated automatically.
5. Right click on the node and select ‘Import Object’. Open the file ‘NodeObject.lbj’; a LonMark compliant node requires a NodeObject.
6. Right click on the node again, and select ‘Import Object’. Open the file ‘6010VSD.lbj’ (Variable Speed Drive Profile object) from the ‘Template’ folder.
7. Add manufacturer specific variables to the project
8. Save the project using the ‘Save as’ function in the ‘File’ menu.
9. If you import Objects and make changes, you may also want to save the object as a new object. To do this, right click on the object and select ‘Save’.
10. Export the project as .XIF, Configuration File and Documentation, see 7-1 “File Management”.)
Chapter 4

The Firmware Download Utility

General

The Firmware Download utility is used to download Configuration Files (.DAT) into the LonWorks interface, previously created using Anybus LWTool. For installation instructions, see 4-1 “Software Installation”.

Configuration

The first time the program is started, it will prompt for some information that is necessary to establish a communication link, a.k.a. a path, towards the LonWorks interface.

The first dialog specifies which hardware interface to use for the communication path. Select ‘ABS-ABS Gateway’ and click ‘OK’. Next, click on ‘Create’.

Select ‘COMport Transport Provider’ and click ‘OK’. Enter a name for the new communication path (This name will be used on all further references to the path).

Select which COM-port to use (in this case, select the one intended for the Anybus X-gateway LonWorks interface).

Select the physical location of the LonWorks interface (Upper or Lower), and a suitable timeout value (The recommended timeout value for serial connections is 20 seconds). Click ‘OK’ to finalize the configuration.

(Note the settings described above can be accessed at a later stage in the ‘Settings’ menu).

Operation

1. Connect a null-modem cable between the Gateway Config connector and the COM port used for the configuration.
2. Ensure that ‘Program Mode’ is set to ‘Configuration’.
3. Open the configuration file using the ‘Open’ entry in the ‘File’ menu
4. Click on the ‘Start’ button. The configuration will now be downloaded into the LonWorks interface.
Technical Specification

Bus Interface Details

- Certification prepared for Lonmark application layer interoperability guidelines V3.2
- 5-pole 5.08 mm Phoenix pluggable screw connector
- Free topology (FT-X1) twisted cable
- 78kbit/s transmission rate
- Supports line powered networks
- Designed according to the LonMark design guidelines
- Bus length: Up to 2000 meters (with repeaters)
- Node-to-node distance: Up to 500 meters
- Number of nodes: Up to 32,385 nodes
  (127 nodes/subnet, 255 subnets/domain)
- Medium Access: Predictive CSMA
- Data types: Peer-to-peer communication
- I/O: 256 input and 256 output network variables
  (max. 512 bytes in & 512 bytes out)

Bus Connector

<table>
<thead>
<tr>
<th>#</th>
<th>Signal</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Shield</td>
<td>Cable shield</td>
</tr>
<tr>
<td>2</td>
<td>GND</td>
<td>Ground</td>
</tr>
<tr>
<td>3</td>
<td>Service Pin</td>
<td>Connecting this pin to GND has the same effect as pushing the service button.</td>
</tr>
<tr>
<td>4</td>
<td>NET B</td>
<td>2-wire LonWorks bus</td>
</tr>
<tr>
<td>5</td>
<td>NET A</td>
<td></td>
</tr>
</tbody>
</table>